Imagevue Community and Support Forums

 
User avatar
globetrotter
Imagevue Expert
Topic Author
Posts: 857
Joined: 18 Oct 2006, 09:16

Problem with picture on textpage

28 Dec 2011, 07:05

I have a problem with the picture on my Home textpage. I doesn't show up anymore in the flash version: http://www.globetrotternet.nl/#/content/Test/

It went wrong, after changing some names of my menu-icons. Before that, everyting was working fine.
But maybe I did change something else, without noticing. All the menu-icons are working fine.
And the picture is also on the server: http://www.globetrotternet.nl/content/H ... s/info.jpg

I also see that the HTML version is not working like it should be: http://www.globetrotternet.nl/?content%2FTest%2F
The picture is visible here, but the Dutch and English version are visible at the same time.

Hopefully anyone has an idea, what I did wrong!?!? :?:

Thank you in advance.
Last edited by globetrotter on 29 Dec 2011, 03:27, edited 1 time in total.
 
User avatar
Martin
Experienced
Posts: 579
Joined: 30 Jan 2011, 20:24

Re: Problem with picture on textpage

28 Dec 2011, 21:25

globetrotter wrote:
I have a problem with the picture on my Home textpage.

In this case I myself would build a new textpage from scratch again and replace this one with the original.
Textpages are quirky things to edit.
globetrotter wrote:
I also see that the HTML version is not working like it should be...
The picture is visible here, but the Dutch and English version are visible at the same time.

Probably, recreating the home-textpage will correct this too.
ImageImage
 
User avatar
globetrotter
Imagevue Expert
Topic Author
Posts: 857
Joined: 18 Oct 2006, 09:16

Re: Problem with picture on textpage

29 Dec 2011, 03:23

I build a new textpage, but have the same problem.

But when I remove the [dutch], [/dutch], [english] and [/english] codes, then the picture is ok: http://www.globetrotternet.nl/#/content/Home/
So it has to be something with the language feature.
 
User avatar
Martin
Experienced
Posts: 579
Joined: 30 Jan 2011, 20:24

Re: Problem with picture on textpage

29 Dec 2011, 04:48

globetrotter wrote:
So it has to be something with the language feature.

A time ago I had the same problems.
Take a look at the html-code, I remember that there was a problem with the line-breaks. Something to do with hard en soft returns.
When I look in my textpage-code I see only these returns: <br />

My code starts like this:
<p>[dutch]<br />

My language-sections are seperated like this:
..... in te zien</a>.[/dutch][english]<br /><img height="130" width="130" src="http://www.m.....

My code ends like this:
..... </a>.[/english]</p>


EDIT:
I found one of my messages on the forum, follow this link:
https://imagevuex.com/forum/viewtopic.php?f=27&t=6961&p=26531&hilit=soft+return#p26531


Maybe this is of some help.
ImageImage
 
User avatar
mjau-mjau
Imagevue Wizard
Posts: 9997
Joined: 29 Sep 2006, 23:37

Re: Problem with picture on textpage

29 Dec 2011, 05:59

Not quite sure what it could be ... When I checked, I guess you have reverted to Dutch only, so a bit hard to diagnose. Could be something with html interfering or breaking up the language tags? Did you try to add them in html mode so that they are added clean and don't break up anything?
 
User avatar
globetrotter
Imagevue Expert
Topic Author
Posts: 857
Joined: 18 Oct 2006, 09:16

Re: Problem with picture on textpage

29 Dec 2011, 06:55

I made a test textpage, so I can experiment a bit: http://www.globetrotternet.nl/#/content/Test/

Here is the html code of the page:
<textformat leading="400"><img src="http://www.globetrotternet.nl/content/Home/plaatjes/info.jpg" height="400" width="640" /></textformat><br /><br />[dutch]<br /><b>WELKOM OP MIJN WEBSITE</b><br /><br /><br />Klik voor de meest recente foto's en filmpjes op een van de onderstaande links om deze foto's te bekijken:<br /><br />
<ul>
<li><a href="#/content/Fotos/Overige%20Landen/Spanje%202011/">Spanje 2011</a></li>
<li><a href="#/content/Fotos/Noord-Amerika/Molen%20De%20Zwaan/">Molen De Zwaan In Holland Michigan (Update)</a></li>
<li><a href="#/content/Fotos/Overige%20Landen/Glasgow%202009/">Glasgow 2009</a></li>
<li><a href="#/content/Fotos/Noord%2DAmerika/Amerika%20en%20Canada%202008/">Amerika &amp; Canada 2008</a></li>
<li><a href="#/content/Fotos/Noord-Amerika/Amerika%20en%20Canada%202008%20%28Filmpjes%29/">Amerika &amp; Canada 2008 (Filmpjes)</a></li>
</ul>
<br />Alle foto's en filmpjes in dit album zijn ook te vinden via het menu (linksboven).<br />Heb je vragen en/of opmerkingen over dit fotoalbum, dan kun je deze doorsturen via het <a href="#/content/Contact/">contactformulier</a>.<br />[/dutch]<br />[english]<br /><b>WELCOME TO MY WEBSITE</b><br /><br /><br />For the newest pictures and movies click on the links below:<br /><br />
<ul>
<li><a href="#/content/Fotos/Overige%20Landen/Spanje%202011/">Spain 2011</a></li>
<li><a href="#/content/Fotos/Noord-Amerika/Molen%20De%20Zwaan/">Windmill De Zwaan In Holland Michigan (Update)</a></li>
<li><a href="#/content/Fotos/Overige%20Landen/Glasgow%202009/">Glasgow 2009</a></li>
<li><a href="#/content/Fotos/Noord%2DAmerika/Amerika%20en%20Canada%202008/">America &amp; Canada 2008</a></li>
<li><a href="#/content/Fotos/Noord-Amerika/Amerika%20en%20Canada%202008%20%28Filmpjes%29/">America &amp; Canada 2008 (Movies)</a></li>
</ul>
<br />All pictures and movies in this gallery can been viewed through the Gallery Menu (in the top left corner).<br />Do you have questions or suggestions about this gallery, then you can send a message with the <a href="#/content/Contact/">contactform</a>.<br />[/english]


Can it be something with the option word wrap option? Or maybe something in version 2.7.6, which I installed last week?
 
User avatar
mjau-mjau
Imagevue Wizard
Posts: 9997
Joined: 29 Sep 2006, 23:37

Re: Problem with picture on textpage

29 Dec 2011, 07:24

Well, I would recommend perhaps packing your entire codes inside the brackets. See this:
http://www.globetrotternet.nl/imagevue. ... tent/Test/
You have some stuff outside the brackets, and some inside. Although theoretically it might work, this may also be why its not working. You even have a <br/> between [/dutch]<br />[english]. I think it might help if you edit the html SRC in the editor, and make sure its like this:
[dutch]entire dutch content here, including image[/dutch][english]entire english content here, including image[/english]
 
User avatar
globetrotter
Imagevue Expert
Topic Author
Posts: 857
Joined: 18 Oct 2006, 09:16

Re: Problem with picture on textpage

29 Dec 2011, 08:37

Yes, that was the problem! Now it is working like it should be.

The strange thing is, that everything worked fine for a long time. Even with my beautiful html code. :D
But I updated last week to 2.7.6. After that I did change the name of the menu-icon of this textpage, and pressed save-text-page.

Thanks you both for all the help and suggestions!!!


Edit:
Now I see the flash version is ok: http://www.globetrotternet.nl/#/content/Home/
But the html version is still wrong: http://www.globetrotternet.nl/?content%2FHome%2F . I see dutch and english version at the same time.
 
User avatar
Nick
Imagevue Hitman
Posts: 2883
Joined: 02 May 2006, 05:13

Re: Problem with picture on textpage

30 Dec 2011, 04:07

Sorry about this, this is a problem in some certain php libraries, just download the latest version it'll fix this.
firedev.com
 
User avatar
globetrotter
Imagevue Expert
Topic Author
Posts: 857
Joined: 18 Oct 2006, 09:16

Re: Problem with picture on textpage

30 Dec 2011, 04:50

As far as I can see everything is fixed now. Thanks again for all the quick support!