mwr
Experienced
Joined: 8 Sep 2009
Posts: 84
My imagevue galleries don't display at all on my iPhone, instead they display an error-message screen including after I click on the "HTML Gallery" link. The presentation I tested is: http://ruthvenphotos.com/s100#/content/s100

Here are two iPhone screen shots, the second one after clicking on the HTML Gallery link.

Image


Image


Re: Error screen on my iPhone
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
First of all you have an old imagevue version that doesn't look on the iPhone too well. But even then - the link is wrong. Just open RuthvenPhotos.com:
Image


But anyway we strongly recommend you to upgrade to the latest gallery. You can check what it looks like on iPhone using this link: http://bit.ly/imagevuex2

Ps. To make a screenshot on the iPhone, just press Home+Sleep buttons simultanously.

_________________
Nick / Phuket, Thailand


Re: Error screen on my iPhone
mwr
Experienced
Joined: 8 Sep 2009
Posts: 84
Thanks. I wasn't aware I was behind on versions. I've downloaded the current one and will install it later today.

Is there a way to get email notifications when new versions are available?


Re: Error screen on my iPhone
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
We have something like this in the pipeline. Right now you can just follow us on twitter, facebook or subscribe to our blog to keep updated.

_________________
Nick / Phuket, Thailand


Re: Error screen on my iPhone
mwr
Experienced
Joined: 8 Sep 2009
Posts: 84
I installed the latest imagevue x2 version and it works, with problems:

1. My html files to display specific content foldsers/shows no longer work. They display the following:

Oops! - This page requires javascript -

Please enable javascript in your browser and reload page.
» Flash gallery

Optionally, you can view the HTML gallery page instead:
» HTML gallery

Imagevue flash photo gallery and slideshow:
»
www.imagevuex.com

2. How do I get rid of the "Gallery Menu" at the top left of a gallery page?

3. How do I get rid of the extraneous information on a photo page, meaning the file name, thumbnail images at the bottom, exif info, etc? It's as if any customizing I had done didn't carry over.

Because my html files don't work, I'm going back to the old version until I can sort out this stuff.


Re: Error screen on my iPhone
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7720
mwr wrote
I installed the latest imagevue x2 version and it works, with problems:

1. My html files to display specific content foldsers/shows no longer work. They display the following:

Oops! - This page requires javascript -

Please enable javascript in your browser and reload page.
» Flash gallery

Optionally, you can view the HTML gallery page instead:
» HTML gallery

Imagevue flash photo gallery and slideshow:
»
http://www.imagevuex.com

Not 100% sure what you mean, or how this was achieved. Do you have a link please?

mwr wrote
2. How do I get rid of the "Gallery Menu" at the top left of a gallery page?

This is your main gallery menu, and should only be removed if you are using a single folder for your gallery of course. How else would a visitor navigate between folders? You can disable it by going to admin -> settings -> menu.mainmenu.enabled ... Disable it!

mwr wrote
3. How do I get rid of the extraneous information on a photo page, meaning the file name, thumbnail images at the bottom, exif info, etc? It's as if any customizing I had done didn't carry over.

Not sure what settings you had earlier, but you had them removed earlier? Then the procedure would be the same. Its all in the admin -> settings page ...

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


Re: Error screen on my iPhone
mwr
Experienced
Joined: 8 Sep 2009
Posts: 84
mwr wrote
I installed the latest imagevue x2 version and it works, with problems:

1. My html files to display specific content foldsers/shows no longer work. They display the following:

>Not 100% sure what you mean, or how this was achieved. Do you have a link please?<


I re-installed the prior version of imagevue so you can't recreate the problem. I use html files located n the root directory of ruthvenphotos.com (where the gallery is located), the model one kindly provided by you, to allow a user to easily access one folder of my gallery at a time which is my preferred way of using the gallery. They work flawlessly with my old version of imagevue but, with the latest version, displayed the error messages shown in my prior post here. I just now moved one of the html files to a subfolder and, accessed from there, displays the same messages. http://ruthvenphotos.com/files/s100.html

mwr wrote
2. How do I get rid of the "Gallery Menu" at the top left of a gallery page?

>This is your main gallery menu, and should only be removed if you are using a single folder for your gallery of course. How else would a visitor navigate between folders? You can disable it by going to admin -> settings -> menu.mainmenu.enabled ... Disable it!<


Got it. I don't want my visitors to navigate between folders. I provide a link to the html file that puts them into one folder only.

mwr wrote
3. How do I get rid of the extraneous information on a photo page, meaning the file name, thumbnail images at the bottom, exif info, etc? It's as if any customizing I had done didn't carry over.

>Not sure what settings you had earlier, but you had them removed earlier? Then the procedure would be the same. Its all in the admin -> settings page ...<


Why didn't my customized prior settings carry over to the new installation after I uploaded the contents of the old config folder back into the new installation? Did I not upload that into the proper place? Your instructions (http://imagevuex.com/documentation/upgrade-imagevue) say to - Upload the content of your “config” folder into iv-includes/config/. However, iv-includes doesn't contain a config folder so, instead, I uploaded to the iv-config folder.


Re: Error screen on my iPhone
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7720
Well, when we release upgrades, sometimes we need to change file structures for the benefit of improvement and advances. Your custom documents are point to files that don't exist. First and foremostly, this is first-stop reason as to why they are not working. For example, they are pointing to:
http://ruthvenphotos.com/files/imagevue ... fobject.js (doesnt exist)
http://ruthvenphotos.com/files/imagevue ... address.js (doesnt exist)
In fact, your server seems to redirect to the root when it can't find the file.

As to why your settings did not transfer correctly, I can not tell you. This depends slightly on what version you were on prior to this, which in some case (like explained int he upgrade document), meant copying over a few files. Since 2.5 though, the upgrade to a newer version should transfer settings automatically ...

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


 
Imagevue Forums HomeForum  View topic - Error screen on my iPhone8 posts